بحث هذه المدونة الإلكترونية

الثلاثاء، 23 أبريل، 2013

How To Restart CUCM Web Interface


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

How To Restart CUCM  Web Interface

To do this you need to restart the Cisco Tomcat service, but first what is Tomcat service:

Apache Tomcat (or simply Tomcat) is an open source web server and servlet container developed by the Apache Software Foundation (ASF). Tomcat implements the Java Servlet and the JavaServer Pages (JSP) specifications from Sun Microsystems, and provides a "pure Java" HTTP web server environment for Java code to run.

To display services running on the CUCM:
admin: utils service list

To restart the Tomcat service or simply start it if it is stopped:
admin: utils service restart Cisco Tomcat

 

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

How To Add Cisco IP Communicator in CUCM


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

How To Add Cisco IP Communicator in CUCM

 

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

الخميس، 18 أبريل، 2013

What Is The Difference Between TFTP Option 150 and TFTP Option 66?


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

What Is The Difference Between TFTP Option 150 and TFTP Option 66?

- DHCP Option 150 is Cisco proprietary. The IEEE standard that matches with this requirement is Option 66. Like option 150, option 66 is used to specify the Name of the TFTP server.

- Option 66 is an open standard juniper supports it. RFC 2132 defines option 66.

- DHCP option 150 supports a list of TFTP servers (Multiple Server IPs).

- DHCP option 66 only supports the IP address or the hostname of a single TFTP server. 

For some third-party SIP phones, it may be necessary to specify Option 66 (the TFTP server DNS name).
 
 

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

الاثنين، 15 أبريل، 2013

How To Manage Access To Cisco Devices Based On Active Directory Authentication


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

How To Manage Access To Cisco Devices Based On Active Directory Authentication

If you have many levels of administrators in your network and you want to give them different privileges, doing so using the local database on Cisco devices is not the optimal, you can grant them access based on the authentication against active directory database where the user will login to the device using his normal user name and password then he will be granted the privilege level that you assigned to his or her group.Note that this lab is done using GNS3 and Windows server 2008 R2.

 

The commands used on Cisco router:

aaa new-model
!
aaa group server radius IAS
 server 192.168.1.50 auth-port 1812 acct-port 1813
!
aaa authentication login userAuthentication local group IAS
aaa authorization exec userAuthorization local group IAS if-authenticated
aaa authorization network userAuthorization local group IAS
aaa accounting exec default start-stop group IAS
aaa accounting system default start-stop group IAS
!
aaa session-id common
radius-server host 192.168.1.50 auth-port 1645 acct-port 1646 key cisco
radius-server host 192.168.1.50 auth-port 1812 acct-port 1813 key cisco
!
privilege exec level 1 show config
privilege exec level 1 show ip interface brief
!
ip radius source-interface fa0/0
!
line vty 0 4
 authorization exec userAuthorization
 login authentication userAuthentication
 transport input ssh telnet
!
line vty 5 15
 authorization exec userAuthorization
 login authentication userAuthentication
 transport input ssh telnet

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

الأربعاء، 10 أبريل، 2013

Cisco CUCM Log on failed Invalid User ID or Password


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

Cisco CUCM Log on failed Invalid User ID or Password
 
 On reason for this error when your password contains space, so you need to reset the password from the CUCM console using the following command:


وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

الخميس، 4 أبريل، 2013

HP Network Simulator: 11- Web Interface


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

HP Network Simulator: 11- Web Interface


 

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

HP Network Simulator: 10- Connecting GNS3 and Simware


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

HP Network Simulator: 10- Connecting GNS3 and Simware


 

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

HP Network Simulator: 9- Simware To Real Network (TFTP Server)


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

HP Network Simulator: 9- Simware To Real Network (TFTP Server)

 

وصلي الله  وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

الثلاثاء، 2 أبريل، 2013

Local directory does not appear on Cisco ip phone (or CIPC)

بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

Local directory does not appear on Cisco ip phone (or CIPC)

To slove this issue, entre the following:
ip http server
telephony-service
    url directories http://192.168.20.1/localdirectory
    service local-directory
    create cnf-files

** 192.168.20.1 is the IP of my CME. 
identify the type of the IP phone:

ephone 1
  type CIPC


Result:
وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

الاثنين، 1 أبريل، 2013

HP Network Simulator: 8- OSPF


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

HP Network Simulator: 8- OSPF

 

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

HP Network Simulator: 7- RIP


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

HP Network Simulator: 7- RIP

 

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

HP Network Simulator: 6- Static Routing


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

HP Network Simulator: 6- Static Routing

 

hardcfg:

R1
AddSerial -local 127.0.0.1 -lport 7001 -dest 127.0.0.1 -dport 7002

AddSerial -local 127.0.0.1 -lport 7003 -dest 127.0.0.1 -dport 7004

R2
AddSerial -local 127.0.0.1 -lport 7002 -dest 127.0.0.1 -dport 7001

AddSerial -local 127.0.0.1 -lport 7008 -dest 127.0.0.1 -dport 7007

AddSerial -local 127.0.0.1 -lport 7009 -dest 127.0.0.1 -dport 7010

R3
AddSerial -local 127.0.0.1 -lport 7004 -dest 127.0.0.1 -dport 7003

AddSerial -local 127.0.0.1 -lport 7007 -dest 127.0.0.1 -dport 7008

AddSerial -local 127.0.0.1 -lport 7011 -dest 127.0.0.1 -dport 7012

R4
AddSerial -local 127.0.0.1 -lport 7010 -dest 127.0.0.1 -dport 7009  

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

HP Network Simulator: 5- Mangaing User interfaces (VTY, CONSOLE)


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

HP Network Simulator: 5- Managing User interfaces (VTY, CONSOLE) 

 

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

السبت، 30 مارس، 2013

HP Network Simulator: 4- Full Mesh Switching Lab


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

HP Network Simulator: 4- Full Mesh Switching Lab


 

hardcfg:

SW1
AddEthNew -speed 1000 -level3 -slot 0 -subslot 0 -local 127.0.0.1 -lport 6001 -dest 127.0.0.1 -dport 6002

AddEthNew -speed 1000 -level3 -slot 0 -subslot 1 -local 127.0.0.1 -lport 6003 -dest 127.0.0.1 -dport 6004

AddEthNew -speed 1000 -level3 -slot 0 -subslot 2 -local 127.0.0.1 -lport 6005 -dest 127.0.0.1 -dport 6006


SW2

AddEthNew -speed 1000 -level3 -slot 0 -subslot 0 -local 127.0.0.1 -lport 6002 -dest 127.0.0.1 -dport 6001

AddEthNew -speed 1000 -level3 -slot 0 -subslot 1 -local 127.0.0.1 -lport 6008 -dest 127.0.0.1 -dport 6007

AddEthNew -speed 1000 -level3 -slot 0 -subslot 2 -local 127.0.0.1 -lport 6009 -dest 127.0.0.1 -dport 6010


SW3
AddEthNew -speed 1000 -level3 -slot 0 -subslot 0 -local 127.0.0.1 -lport 6006 -dest 127.0.0.1 -dport 6005

AddEthNew -speed 1000 -level3 -slot 0 -subslot 1 -local 127.0.0.1 -lport 6007 -dest 127.0.0.1 -dport 6008

AddEthNew -speed 1000 -level3 -slot 0 -subslot 2 -local 127.0.0.1 -lport 6011 -dest 127.0.0.1 -dport 6012


SW4

AddEthNew -speed 1000 -level3 -slot 0 -subslot 0 -local 127.0.0.1 -lport 6010 -dest 127.0.0.1 -dport 6009

AddEthNew -speed 1000 -level3 -slot 0 -subslot 1 -local 127.0.0.1 -lport 6004 -dest 127.0.0.1 -dport 6003

AddEthNew -speed 1000 -level3 -slot 0 -subslot 2 -local 127.0.0.1 -lport 6012 -dest 127.0.0.1 -dport 6011  

وصلي الله وسلم وبارك علي النبي وآله و صحبه وإخوانه وسلم

HP Network Simulator: 3- 2 Switches Lab


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

HP Network Simulator: 3- 2 Switches Lab
   

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

HP Network Simulator: 2- Tow Routers Lab


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

HP Network Simulator: 2- Tow Routers Lab
 

وصلي الله وسلم وبارك علي النبي وآله وصحبه  وإخوانه وسلم

HP Network Simulator: 1-Intro


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

HP Network Simulator: 1-Intro

 

Download Simulator

بسم الله

password: amnetwork.blogspot.com

 وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

الأحد، 24 مارس، 2013

Class Of Restriction (COR) Superset Or Subset


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

Class Of Restriction (COR) Superset Or Subset

Keep in mind the following rule:
- for a call to be successful the incoming COR must be a superset or equal to the outgoing COR.
- to deny a call the incoming COR must be a subset of the outgoing COR.


Lab Time:

 
Example 1 : Call fail ( the incoming COR is a subset of the outgoing COR)
R1:
dial-peer cor custom
name sales
name accounting
name laboratory
!
dial-peer cor list sales-out
member sales
member accounting
member laboratory
!
dial-peer cor list sales-in
member sales
member accounting
!
ephone-dn 1
cor incoming sales-in
!
dial-peer voice 1 voip
cor outgoing sales-out

Result: 



Example 2 : Call Success (the incoming COR is equal to the outgoing COR)
R1:
dial-peer cor custom
name sales
name accounting
name laboratory
!
dial-peer cor list sales-out
member sales
member accounting
member laboratory
!
dial-peer cor list sales-in
member sales
member accounting
member laboratory
!
ephone-dn 1
cor incoming sales-in
!
dial-peer voice 1 voip
cor outgoing sales-out

Result:


ولا تنسوني والمسلمين من صالح الدعاء

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

السبت، 23 مارس، 2013

Class Of Restriction (COR) Lab Using GNS3


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

Class Of Restriction (COR) Lab Using GNS3

- First Keep in mind the following:

Each dial-peer or phone-dn can have one incoming COR list and one outgoing COR list:
- Incoming COR list means: the dial-peer or the phone can initiate calls or not.
- outgoing COR list means: who can call this dial-peer or phone or not.
- If no incoming COR list: this means that the dial-peer or the phone can call any one. Regardless of the outgoing COR setting on the phone called
- if no outgoing COR list: this means that anyone can call this dial-peer or phone regardless if the phone calling has an incoming COR set or not.
- If the incoming COR list is a superset or equal to the outgoing COR list this means that the call will succeed.
- If the incoming COR list is not a superset or equal to the outgoing COR list this means that the call will fail.
- When you begin configuration first you need to configure the outgoing COR.
- To deny a call when you configure the outgoing COR make sure that it is a superset of the incoming COR.
   Now it is Lab time:
 - The Manager can call the Employee but the Employee can not. Also the Employee should call any other dial-peer.
dial-peer cor custom
name employee
name manager
!
dial-peer cor list Manager
member manager
!
dial-peer cor list Employee
member employee
!
ephone-dn 1
cor outgoing Manager
!
ephone-dn 2
cor incoming Employee

- Results:



ولا تنسوني و المسلمين من صالح الدعاء

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم

الجمعة، 15 مارس، 2013

H3C And HP Networking

بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

H3C And HP  Networking

H3C was initially a joint venture agreement between 3Com and Huawei.
They set up a company called H3C which had a majority control to Huawei however in the agreement 3Com could buy a controlling share a few years later.
In 2007 3Com bought over H3C completely and as such it became an arm of 3Com.
H3C is massive is China and sells enterprise gear which is meant to compete with Cisco.
The interface which the H3C devices use is very similar to the CLI to Cisco with differences in some commands.
By the way All huawei datacom devices use the same os called vrp (versatile Routing Platform) which is very similar to H3C's OS (Comware).
All equipment was rebranded as H3C at this point and as such 3Com on network devices disappeared.
On April 12, 2010, Hewlett-Packard (HP) completed the acquisition of 3Com and the 3Com brand has been disappered all together with a new HP brand covering all the network gear.
However H3C will remain the brand in China as it is a massive brand over there and they don't want to risk losing the market due to a brand name change.

H3C’s O/S, Comware 5 is similar to IOS in its structure and command set, it is not “copied IOS”.
Comware 5 was written from scratch (a complete rewrite from Comware 3).
The drivers are of course different on the various products, but all the features exist in the code on every product,
and Comware 5 does not use a feature set model to unlock them.

The HP ProVision operating system (which is very similar to Cisco's IOS) runs on HP 3500, 5400zl, 6200yl, 6600, and 8200zl Switch Series.
Other HP switches use an operating system that is very similar to the ProVision operating system.

But why am i writing this post today?
as you know my main concern in IT study is: does the vendor has a simulator (emulator will better) or no? because this which makes me continue in the study.
Huwaei and 3COM has a simulator for H3C prouducts which HP now provides this simulator to their partners only. it based on Comware 5:
[H3C] display ver
H3C Comware Platform Software
Comware Software, Version 5.20, Release 9101
Copyright (c) 2004-2010 Hangzhou H3C Tech. Co., Ltd. All rights reserved.
SIMWARE uptime is 0 week, 0 day, 0 hour, 0 minute

This if you are in the situation where you have  HP network project and you have to study for it, it is now available.

I hope that has been informative to you.

ولا تنسوني والمسلمين من صالح الدعاء

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم 

الاثنين، 11 مارس، 2013

How to Simulate PSTN Using GNS3


بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

How to Simulate PSTN Using GNS3

 

This is my initial CCNA VOICE lab using GNS3. The most important in this post is how to simulate the Public Switched Telephone Network (PSTN). As you know currently GNS3 does not support FXS or FXO ports, so the following configuration showing you how to get around this by Allah’s willing.
So, I have used the following IOS:
(C3745-IPVOICE_IVS-M), Version 12.4(15)T14
It is the same on all routers and the PSTN, this is to decrease the processor load. Because as you know GNS3 uses the ghost image feature which uses a single IOS on all routers from the same type instead of using a dedicated image for each router.


HQ:
voice service voip
 allow-connections h323 to h323
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.10.10.1
!
interface FastEthernet0/0
 ip address 192.168.20.1 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 172.17.20.2 255.255.255.252
 speed 100
 full-duplex
!
interface Serial1/1
 ip address 172.16.10.5 255.255.255.252
 serial restart-delay 0
!
interface Serial1/2
 ip address 172.16.10.1 255.255.255.252
 serial restart-delay 0
!
router eigrp 100
 passive-interface FastEthernet0/0
 network 0.0.0.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.17.20.1
!
dial-peer voice 2 voip
 destination-pattern 10..
 session target ipv4:172.16.10.2
!
dial-peer voice 3 voip
 destination-pattern 20..
 session target ipv4:172.16.10.6
!
dial-peer voice 1 voip
 destination-pattern .T
 session target ipv4:10.10.10.10
 incoming called-number .
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
telephony-service
 max-ephones 20
 max-dn 20
 ip source-address 192.168.20.1 port 2000
 max-conferences 8 gain -6
 transfer-system full-consult
!
ephone-dn  1  dual-line
 number 3010
!
ephone-dn  2  dual-line
 number 3011
!
ephone  1
 mac-address 000C.29DE.9093
 type CIPC
 button  1:1 2:2
!

BR1:
voice service voip
 allow-connections h323 to h323
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.10.10.2
!
interface FastEthernet0/0
 ip address 192.168.10.1 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 172.17.30.2 255.255.255.252
 speed 100
 full-duplex
!
interface Serial1/0
 ip address 172.16.10.10 255.255.255.252
 serial restart-delay 0
!
interface Serial1/2
 ip address 172.16.10.2 255.255.255.252
 serial restart-delay 0
!
router eigrp 100
 passive-interface FastEthernet0/0
 network 0.0.0.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.17.30.1
!
dial-peer voice 2 voip
 destination-pattern 30..
 session target ipv4:172.16.10.1
!
dial-peer voice 3 voip
 destination-pattern 20..
 session target ipv4:172.16.10.9
!
dial-peer voice 1 voip
 destination-pattern .T
 session target ipv4:10.10.10.10
 incoming called-number .
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
telephony-service
 max-ephones 20
 max-dn 20
 ip source-address 192.168.10.1 port 2000
 max-conferences 8 gain -6
 transfer-system full-consult
!
ephone-dn  1  dual-line
 number 1010
!
ephone-dn  2  dual-line
 number 1011
!
ephone  1
 mac-address 000C.2909.DB4B
 type CIPC
 button  1:1 2:2
!

BR2:
voice service voip
 allow-connections h323 to h323
!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.10.10.3
!
interface FastEthernet0/0
 ip address 192.168.40.1 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 172.17.10.2 255.255.255.252
 speed 100
 full-duplex
!
interface Serial1/0
 ip address 172.16.10.9 255.255.255.252
 serial restart-delay 0
!
interface Serial1/1
 ip address 172.16.10.6 255.255.255.252
 serial restart-delay 0
!
router eigrp 100
 passive-interface FastEthernet0/0
 network 0.0.0.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.17.10.1
!
dial-peer voice 2 voip
 destination-pattern 10..
 session target ipv4:172.16.10.10
!
dial-peer voice 3 voip
 destination-pattern 30..
 session target ipv4:172.16.10.5
!
dial-peer voice 1 voip
 destination-pattern .T
 session target ipv4:10.10.10.10
 incoming called-number .
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
telephony-service
 max-ephones 20
 max-dn 20
 ip source-address 192.168.40.1 port 2000
 max-conferences 8 gain -6
 transfer-system full-consult
!
ephone-dn  1  dual-line
 number 2010
!
ephone-dn  2  dual-line
 number 2011
!
ephone  1
 mac-address 000C.291A.F96B
 type CIPC
 button  1:1 2:2
!

PSTN:
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.10.10.10
!
interface FastEthernet0/0
 ip address 192.168.1.99 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet1/0
 no switchport
 ip address 172.17.20.1 255.255.255.252
 speed 100
!
interface FastEthernet1/1
 no switchport
 ip address 172.17.30.1 255.255.255.252
 speed 100
!
interface FastEthernet1/2
 no switchport
 ip address 172.17.10.1 255.255.255.252
 speed 100
!
ip route 10.10.10.1 255.255.255.255 172.17.20.2
ip route 10.10.10.2 255.255.255.255 172.17.30.2
ip route 10.10.10.3 255.255.255.255 172.17.10.2
!
dial-peer voice 1 voip
 incoming called-number .
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2 voip
 description *** HQ ***
 destination-pattern 30..
 session target ipv4:10.10.10.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 3 voip
 description *** BR1 ***
 destination-pattern 10..
 session target ipv4:10.10.10.2
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 4 voip
 description *** BR2 ***
 destination-pattern 20..
 session target ipv4:10.10.10.3
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
telephony-service
 max-ephones 20
 max-dn 20
 ip source-address 192.168.1.99 port 2000
 max-conferences 8 gain -6
 transfer-system full-consult
!
ephone-dn  1  dual-line
 number 125
!
ephone-dn  2  dual-line
 number 3645258
!
ephone-dn  3  dual-line
 number 4256821
!
ephone-dn  4  dual-line
 number 5425681
!
ephone  1
 mac-address 00E0.4C04.E85F
 type CIPC
 button  1:1 2:2 3:3 4:4
!

Making some rings between PSTN and the internal:



ولا تنسوني والمسلمين من صالح الدعاء

وصلي الله وسلم وبارك علي النبي وآله وصحبه وإخوانه وسلم